equired PHP version greater than equal to 5.4.0 AND found version is : 5.3.29 – Softaculous Prestashop not picking up correct php version – Knowledgebase


equired PHP version greater than equal to 5.4.0 AND found version is : 5.3.29 – Softaculous Prestashop not picking up correct php version

You may come across an issue while installing Prestashop via Softaculous regarding not picking up correct php version.

The error would look similar to the error below –

The following errors were found : Required PHP version greater than equal to 5.4.0 AND found version is : 5.3.29


Solution :
1. Modify the file where softaculous is installed on the server –
/usr/local/cpanel/whostmgr/docroot/cgi/softaculous/enduser/hooks/pre_install.php

2. Make a copy of pre_install.php file before you make any changes.

3. Now, add below code and replace $version = phpversion(); with $version = 5.6;

    function __pre_install()
   {

    global $soft, $software, $globals;
    // Your Code to Identify the PHP version
    // E.g
   $version = phpversion();
   define(‘php_version’, $version);
   }

 Give a try to re-install prestashop via Softaculous and this should work for you.

Also Read

Powered by WHMCompleteSolution

Leave a Comment

Your email address will not be published. Required fields are marked *

Open chat